re = /^(?=(?:\D*\d){10}(?:(?:\D*\d){3})?$)[\d-]+$/m
str = '978-1-56619-909-4 2
978-1-56619-909-4
1-56619-909-3
1-56619-909-3
isbn446877428ydh
55 65465 4513574
1257561035
1248752418865'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end