use strict;
my $str = '978-1-56619-909-4 2
978-1-56619-909-4
1-56619-909-3
1-56619-909-3
isbn446877428ydh
55 65465 4513574
1257561035
1248752418865';
my $regex = qr/^(?=(?:\D*\d){10}(?:(?:\D*\d){3})?$)[\d-]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}