import re
regex = re.compile(r"^(?=(?:\D*\d){10}(?:(?:\D*\d){3})?$)[\d-]+$", flags=re.MULTILINE)
test_str = ("978-1-56619-909-4 2\n"
"978-1-56619-909-4\n"
"1-56619-909-3 \n"
"1-56619-909-3\n"
"isbn446877428ydh\n"
"55 65465 4513574\n"
"1257561035\n"
"1248752418865")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")