using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<value>\d+(?:\.\d+)?)(?<unit>[kmbt]?)";
string input = @"'300', '3k', '3.2k', '0.0001k', '$15', '$30k', 1000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}