// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<value>\d+(?:\.\d+)?)(?<unit>[kmbt]?)").unwrap();
let string = "'300', '3k', '3.2k', '0.0001k', '$15', '$30k', 1000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}