const regex = /(?<value>\d+(?:\.\d+)?)(?<unit>[kmbt]?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<value>\\d+(?:\\.\\d+)?)(?<unit>[kmbt]?)', 'g')
const str = `'300', '3k', '3.2k', '0.0001k', '\$15', '\$30k', 1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}