package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<value>\d+(?:\.\d+)?)(?<unit>[kmbt]?)`)
var str = `'300', '3k', '3.2k', '0.0001k', '$15', '$30k', 1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}