#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?:https?://)?(?:w{3}\.)?(?:\w+\.){1,2}\pL{2,}+(?:/\S+)?$"
Local $sString = "https://www.php.net/manual/" & @CRLF & _
"mail.google.com/mail/u/0/?tab=rm&ogbl#inbox" & @CRLF & _
"https://сайтыобразованию.рф" & @CRLF & _
"php.net" & @CRLF & _
"Слово.Слово"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")