re = /^(?:https?:\/\/)?(?:w{3}\.)?(?:\w+\.){1,2}\pL{2,}+(?:\/\S+)?$/m
str = 'https://www.php.net/manual/
mail.google.com/mail/u/0/?tab=rm&ogbl#inbox
https://сайтыобразованию.рф
php.net
Слово.Слово'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end