const regex = new RegExp('^(?:https?://)?(?:w{3}\\.)?(?:\\w+\\.){1,2}\\pL{2,}+(?:/\\S+)?$', 'ugm')
const str = `https://www.php.net/manual/
mail.google.com/mail/u/0/?tab=rm&ogbl#inbox
https://сайтыобразованию.рф
php.net
Слово.Слово`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}