import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?://)?(?:w{3}\\.)?(?:\\w+\\.){1,2}\\pL{2,}+(?:/\\S+)?$";
final String string = "https://www.php.net/manual/\n"
+ "mail.google.com/mail/u/0/?tab=rm&ogbl#inbox\n"
+ "https://сайтыобразованию.рф\n"
+ "php.net\n"
+ "Слово.Слово";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}