$re = '~^(?:https?://)?(?:w{3}\.)?(?:\w+\.){1,2}\pL{2,}+(?:/\S+)?$~um';
$str = 'https://www.php.net/manual/
mail.google.com/mail/u/0/?tab=rm&ogbl#inbox
https://сайтыобразованию.рф
php.net
Слово.Слово';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);