using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?://)?(?:w{3}\.)?(?:\w+\.){1,2}\pL{2,}+(?:/\S+)?$";
string input = @"https://www.php.net/manual/
mail.google.com/mail/u/0/?tab=rm&ogbl#inbox
https://сайтыобразованию.рф
php.net
Слово.Слово";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}