#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\d+)([" "])\1\2\1$"
Local $sString = "+shoud match" & @CRLF & _
"42 42 42" & @CRLF & _
"100 100 100" & @CRLF & _
"10 10 10" & @CRLF & _
"" & @CRLF & _
"-shoud not match" & @CRLF & _
"42 42 42 42" & @CRLF & _
"42 42" & @CRLF & _
"101 102 103" & @CRLF & _
"1 2 3" & @CRLF & _
"42\t42\t42" & @CRLF & _
"42 42 42"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")