import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+)([\" \"])\\1\\2\\1$";
final String string = "+shoud match\n"
+ "42 42 42\n"
+ "100 100 100\n"
+ "10 10 10\n\n"
+ "-shoud not match\n"
+ "42 42 42 42\n"
+ "42 42\n"
+ "101 102 103\n"
+ "1 2 3\n"
+ "42\\t42\\t42\n"
+ "42 42 42";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}