$re = '/^(\d+)([" "])\1\2\1$/mi';
$str = '+shoud match
42 42 42
100 100 100
10 10 10
-shoud not match
42 42 42 42
42 42
101 102 103
1 2 3
42\\t42\\t42
42 42 42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);