const regex = /^(\d+)([" "])\1\2\1$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)([" "])\\1\\2\\1$', 'gmi')
const str = `+shoud match
42 42 42
100 100 100
10 10 10
-shoud not match
42 42 42 42
42 42
101 102 103
1 2 3
42\\t42\\t42
42 42 42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}