using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)(["" ""])\1\2\1$";
string input = @"+shoud match
42 42 42
100 100 100
10 10 10
-shoud not match
42 42 42 42
42 42
101 102 103
1 2 3
42\t42\t42
42 42 42";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}