use strict;
my $str = '+shoud match
42 42 42
100 100 100
10 10 10
-shoud not match
42 42 42 42
42 42
101 102 103
1 2 3
42\\t42\\t42
42 42 42';
my $regex = qr/^(\d+)([" "])\1\2\1$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}