#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*<\w+>(.+)</\w+>\s*$"
Local $sString = "<?xml version="1.0" ?>" & @CRLF & _
"<reply>" & @CRLF & _
" <result>ERROR</result>" & @CRLF & _
" <code>1</code>" & @CRLF & _
" <status>Not Delivered</status>" & @CRLF & _
" <description>failed to send 1 message</description>" & @CRLF & _
" <message_infos>" & @CRLF & _
" <message_info>" & @CRLF & _
" <phone>79051112233</phone>" & @CRLF & _
" <sms_id>1000472891</sms_id>" & @CRLF & _
" </message_info>" & @CRLF & _
" </message_infos>" & @CRLF & _
"</reply>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")