use strict;
my $str = '<?xml version="1.0" ?>
<reply>
<result>ERROR</result>
<code>1</code>
<status>Not Delivered</status>
<description>failed to send 1 message</description>
<message_infos>
<message_info>
<phone>79051112233</phone>
<sms_id>1000472891</sms_id>
</message_info>
</message_infos>
</reply>';
my $regex = qr`^\s*<\w+>(.+)</\w+>\s*$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}