package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*<\w+>(.+)</\w+>\s*$`)
var str = `<?xml version="1.0" ?>
<reply>
<result>ERROR</result>
<code>1</code>
<status>Not Delivered</status>
<description>failed to send 1 message</description>
<message_infos>
<message_info>
<phone>79051112233</phone>
<sms_id>1000472891</sms_id>
</message_info>
</message_infos>
</reply>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}