// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*<\w+>(.+)</\w+>\s*$").unwrap();
let string = "<?xml version=\"1.0\" ?>
<reply>
<result>ERROR</result>
<code>1</code>
<status>Not Delivered</status>
<description>failed to send 1 message</description>
<message_infos>
<message_info>
<phone>79051112233</phone>
<sms_id>1000472891</sms_id>
</message_info>
</message_infos>
</reply>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}