re = /^\s*<\w+>(.+)<\/\w+>\s*$/m
str = '<?xml version="1.0" ?>
<reply>
<result>ERROR</result>
<code>1</code>
<status>Not Delivered</status>
<description>failed to send 1 message</description>
<message_infos>
<message_info>
<phone>79051112233</phone>
<sms_id>1000472891</sms_id>
</message_info>
</message_infos>
</reply>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end