using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*<\w+>(.+)</\w+>\s*$";
string input = @"<?xml version=""1.0"" ?>
<reply>
<result>ERROR</result>
<code>1</code>
<status>Not Delivered</status>
<description>failed to send 1 message</description>
<message_infos>
<message_info>
<phone>79051112233</phone>
<sms_id>1000472891</sms_id>
</message_info>
</message_infos>
</reply>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}