using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?<protocol>[a-z]+):\/\/)?
(?:(?:(?<username>[^@\r\n:]+))
(?::(?<password>[^@\r\n]+))?@)?
(?<host>[^\/:\r\n]+)
(?::(?<port>\d+))?
(?:\/(?<path>[^?\r\n]+)?)?
(?:\?(?<query>[^\r\n]+))?";
string input = @"http://server:12345/path/blabla
http://server.com:1234/path?query_string#fragment_id
ftp://user:password@server:1234/path
ftp://user@server:1234/path
http://www.server.com
www.server.com/path
server.com
http://user@server.com:1234/path?query_string#fragment_id
user@server.com:1234
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}