// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)^(?:(?<protocol>[a-z]+):\/\/)?
(?:(?:(?<username>[^@\r\n:]+))
(?::(?<password>[^@\r\n]+))?@)?
(?<host>[^\/:\r\n]+)
(?::(?<port>\d+))?
(?:\/(?<path>[^?\r\n]+)?)?
(?:\?(?<query>[^\r\n]+))?").unwrap();
let string = "http://server:12345/path/blabla
http://server.com:1234/path?query_string#fragment_id
ftp://user:password@server:1234/path
ftp://user@server:1234/path
http://www.server.com
www.server.com/path
server.com
http://user@server.com:1234/path?query_string#fragment_id
user@server.com:1234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}