package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<protocol>[a-z]+):\/\/)?
(?:(?:(?<username>[^@\r\n:]+))
(?::(?<password>[^@\r\n]+))?@)?
(?<host>[^\/:\r\n]+)
(?::(?<port>\d+))?
(?:\/(?<path>[^?\r\n]+)?)?
(?:\?(?<query>[^\r\n]+))?`)
var str = `http://server:12345/path/blabla
http://server.com:1234/path?query_string#fragment_id
ftp://user:password@server:1234/path
ftp://user@server:1234/path
http://www.server.com
www.server.com/path
server.com
http://user@server.com:1234/path?query_string#fragment_id
user@server.com:1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}