import Foundation
let pattern = #"""
^(?:(?<protocol>[a-z]+):\/\/)?
(?:(?:(?<username>[^@\r\n:]+))
(?::(?<password>[^@\r\n]+))?@)?
(?<host>[^\/:\r\n]+)
(?::(?<port>\d+))?
(?:\/(?<path>[^?\r\n]+)?)?
(?:\?(?<query>[^\r\n]+))?
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = ##"""
http://server:12345/path/blabla
http://server.com:1234/path?query_string#fragment_id
ftp://user:password@server:1234/path
ftp://user@server:1234/path
http://www.server.com
www.server.com/path
server.com
http://user@server.com:1234/path?query_string#fragment_id
user@server.com:1234
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)