const regex = /^(?:(?<protocol>[a-z]+):\/\/)?
(?:(?:(?<username>[^@\r\n:]+))
(?::(?<password>[^@\r\n]+))?@)?
(?<host>[^\/:\r\n]+)
(?::(?<port>\d+))?
(?:\/(?<path>[^?\r\n]+)?)?
(?:\?(?<query>[^\r\n]+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<protocol>[a-z]+):\\\/\\\/)?
(?:(?:(?<username>[^@\\r\\n:]+))
(?::(?<password>[^@\\r\\n]+))?@)?
(?<host>[^\\\/:\\r\\n]+)
(?::(?<port>\\d+))?
(?:\\\/(?<path>[^?\\r\\n]+)?)?
(?:\\?(?<query>[^\\r\\n]+))?', 'gm')
const str = `http://server:12345/path/blabla
http://server.com:1234/path?query_string#fragment_id
ftp://user:password@server:1234/path
ftp://user@server:1234/path
http://www.server.com
www.server.com/path
server.com
http://user@server.com:1234/path?query_string#fragment_id
user@server.com:1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}