use strict;
my $str = 'http://server:12345/path/blabla
http://server.com:1234/path?query_string#fragment_id
ftp://user:password@server:1234/path
ftp://user@server:1234/path
http://www.server.com
www.server.com/path
server.com
http://user@server.com:1234/path?query_string#fragment_id
user@server.com:1234
';
my $regex = qr/^(?:(?<protocol>[a-z]+):\/\/)?
(?:(?:(?<username>[^@\r\n:]+))
(?::(?<password>[^@\r\n]+))?@)?
(?<host>[^\/:\r\n]+)
(?::(?<port>\d+))?
(?:\/(?<path>[^?\r\n]+)?)?
(?:\?(?<query>[^\r\n]+))?/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}