#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(https?:\/\/[^?]*\??.*?)([&?]filter_productnaam-leverancier=)(.*)"
Local $sString = "https://lampgigant.nl/lampen/hanglampen/?filter_productnaam-leverancier=galileo-pendel-14xg420w-d93cm-wit%2Ccosmo-pendel-led-10wd30cm-3000k-920lm-ch&query_type_productnaam-leverancier=or"
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)