package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/[^?]*\??.*?)([&?]filter_productnaam-leverancier=)(.*)`)
var str = []byte(`https://lampgigant.nl/lampen/hanglampen/?filter_productnaam-leverancier=galileo-pendel-14xg420w-d93cm-wit%2Ccosmo-pendel-led-10wd30cm-3000k-920lm-ch&query_type_productnaam-leverancier=or`)
var substitution = []byte("\1\3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}