// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/[^?]*\??.*?)([&?]filter_productnaam-leverancier=)(.*)").unwrap();
let string = "https://lampgigant.nl/lampen/hanglampen/?filter_productnaam-leverancier=galileo-pendel-14xg420w-d93cm-wit%2Ccosmo-pendel-led-10wd30cm-3000k-920lm-ch&query_type_productnaam-leverancier=or";
let substitution = "\\1\\3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}