use strict;
my $str = 'https://lampgigant.nl/lampen/hanglampen/?filter_productnaam-leverancier=galileo-pendel-14xg420w-d93cm-wit%2Ccosmo-pendel-led-10wd30cm-3000k-920lm-ch&query_type_productnaam-leverancier=or';
my $regex = qr/(https?:\/\/[^?]*\??.*?)([&?]filter_productnaam-leverancier=)(.*)/p;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";