import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/[^?]*\\??.*?)([&?]filter_productnaam-leverancier=)(.*)";
final String string = "https://lampgigant.nl/lampen/hanglampen/?filter_productnaam-leverancier=galileo-pendel-14xg420w-d93cm-wit%2Ccosmo-pendel-led-10wd30cm-3000k-920lm-ch&query_type_productnaam-leverancier=or";
final String subst = "\\1\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}