$re = '/(https?:\/\/[^?]*\??.*?)([&?]filter_productnaam-leverancier=)(.*)/';
$str = 'https://lampgigant.nl/lampen/hanglampen/?filter_productnaam-leverancier=galileo-pendel-14xg420w-d93cm-wit%2Ccosmo-pendel-led-10wd30cm-3000k-920lm-ch&query_type_productnaam-leverancier=or';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;