#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?:\/\/)?(www\.)?(\w{3})(\.(com|edu|gov))?(\.br)?"
Local $sString = "http://www.google.com.br" & @CRLF & _
"https://www.yahoo.edu" & @CRLF & _
"http://mec.gov.br" & @CRLF & _
"ufmt.br" & @CRLF & _
"www.abc_xyz.com" & @CRLF & _
"abc123456789.com "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")