re = /(https?:\/\/)?(www\.)?(\w{3})(\.(com|edu|gov))?(\.br)?/
str = 'http://www.google.com.br
https://www.yahoo.edu
http://mec.gov.br
ufmt.br
www.abc_xyz.com
abc123456789.com '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end