$re = '/(https?:\/\/)?(www\.)?(\w{3})(\.(com|edu|gov))?(\.br)?/';
$str = 'http://www.google.com.br
https://www.yahoo.edu
http://mec.gov.br
ufmt.br
www.abc_xyz.com
abc123456789.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);