// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/)?(www\.)?(\w{3})(\.(com|edu|gov))?(\.br)?").unwrap();
let string = "http://www.google.com.br
https://www.yahoo.edu
http://mec.gov.br
ufmt.br
www.abc_xyz.com
abc123456789.com ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}