const regex = /(https?:\/\/)?(www\.)?(\w{3})(\.(com|edu|gov))?(\.br)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www\\.)?(\\w{3})(\\.(com|edu|gov))?(\\.br)?', 'g')
const str = `http://www.google.com.br
https://www.yahoo.edu
http://mec.gov.br
ufmt.br
www.abc_xyz.com
abc123456789.com `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}