using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w[\s\S]*?\w)$(?=(?:\s^\w|\z))";
string input = @"Host myserver
HostName somedns1
User abcuser
IdentityFile ~/.ssh/id_rsa
Host myserver2
HostName someotherdns2
User yourmum
PreferredAuthentications publickey
IdentityFile ~/.ssh/id_yourmum_rsa
Other sdofmwerf
something some
haha ha
Host myserver3
HostName someotherdns23
PreferredAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key
Host myserver4
HostName someotherdns532
PrefferedAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}