const regex = /^(\w[\s\S]*?\w)$(?=(?:\s^\w|\z))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w[\\s\\S]*?\\w)$(?=(?:\\s^\\w|\\z))', 'gm')
const str = `Host myserver
HostName somedns1
User abcuser
IdentityFile ~/.ssh/id_rsa
Host myserver2
HostName someotherdns2
User yourmum
PreferredAuthentications publickey
IdentityFile ~/.ssh/id_yourmum_rsa
Other sdofmwerf
something some
haha ha
Host myserver3
HostName someotherdns23
PreferredAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key
Host myserver4
HostName someotherdns532
PrefferedAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}