import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w[\\s\\S]*?\\w)$(?=(?:\\s^\\w|\\z))";
final String string = "Host myserver\n"
+ " HostName somedns1\n"
+ " User abcuser\n"
+ " IdentityFile ~/.ssh/id_rsa\n"
+ "Host myserver2\n"
+ " HostName someotherdns2\n"
+ " User yourmum\n"
+ " PreferredAuthentications publickey\n"
+ " IdentityFile ~/.ssh/id_yourmum_rsa\n"
+ "Other sdofmwerf\n"
+ " something some\n"
+ " haha ha\n"
+ "Host myserver3\n"
+ " HostName someotherdns23\n"
+ " PreferredAuthentications publickey\n"
+ " User root\n"
+ " IdentityFile ~/.ssh/deploy.key\n"
+ "Host myserver4\n"
+ " HostName someotherdns532\n"
+ " PrefferedAuthentications publickey\n"
+ " User root\n"
+ " IdentityFile ~/.ssh/deploy.key";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}