use strict;
my $str = 'Host myserver
HostName somedns1
User abcuser
IdentityFile ~/.ssh/id_rsa
Host myserver2
HostName someotherdns2
User yourmum
PreferredAuthentications publickey
IdentityFile ~/.ssh/id_yourmum_rsa
Other sdofmwerf
something some
haha ha
Host myserver3
HostName someotherdns23
PreferredAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key
Host myserver4
HostName someotherdns532
PrefferedAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key';
my $regex = qr/^(\w[\s\S]*?\w)$(?=(?:\s^\w|\z))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}