re = /^(\w[\s\S]*?\w)$(?=(?:\s^\w|\z))/m
str = 'Host myserver
HostName somedns1
User abcuser
IdentityFile ~/.ssh/id_rsa
Host myserver2
HostName someotherdns2
User yourmum
PreferredAuthentications publickey
IdentityFile ~/.ssh/id_yourmum_rsa
Other sdofmwerf
something some
haha ha
Host myserver3
HostName someotherdns23
PreferredAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key
Host myserver4
HostName someotherdns532
PrefferedAuthentications publickey
User root
IdentityFile ~/.ssh/deploy.key'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end