import re
regex = re.compile(r"^(\w[\s\S]*?\w)$(?=(?:\s^\w|\z))", flags=re.MULTILINE)
test_str = ("Host myserver\n"
" HostName somedns1\n"
" User abcuser\n"
" IdentityFile ~/.ssh/id_rsa\n"
"Host myserver2\n"
" HostName someotherdns2\n"
" User yourmum\n"
" PreferredAuthentications publickey\n"
" IdentityFile ~/.ssh/id_yourmum_rsa\n"
"Other sdofmwerf\n"
" something some\n"
" haha ha\n"
"Host myserver3\n"
" HostName someotherdns23\n"
" PreferredAuthentications publickey\n"
" User root\n"
" IdentityFile ~/.ssh/deploy.key\n"
"Host myserver4\n"
" HostName someotherdns532\n"
" PrefferedAuthentications publickey\n"
" User root\n"
" IdentityFile ~/.ssh/deploy.key")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")