# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.*?(@\S*))|(.*)/$1/ig;t' <<< "blah blah blah @abc blah @bcd blah blah
test@ibe @i slkjhk idsufyiu @uh "