use strict;
my $str = 'blah blah blah @abc blah @bcd blah blah
test@ibe @i slkjhk idsufyiu @uh ';
my $regex = qr/(?:.*?(@\S*))|(.*)/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";